Halomods Community Portal: [APP] Orbit - Halomods Community Portal

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

H2X
[APP] Orbit

A 3D, halo 2 map renderer and editor

#21 User is offline   Xerax 

  • Double Faggot
  • PipPipPip
  • Group: Members
  • Joined: 07-May 11
  • LocationLondon, UK

Posted 10 August 2011 - 03:58 PM

View Postmojobojo, on 09 August 2011 - 05:58 AM, said:

I have it set to "Debug" and "Mixed Platforms", the xna framework 3.0, 3.1, and 4.0 are installed. I could not upgrade the project to VS 2010 for XNA 4.0 though.

An unhandled exception of type 'System.IO.FileNotFoundException' occurred in Orbit.exe

Additional information: Could not load file or assembly 'Microsoft.Xna.Framework, Version=3.1.0.0, Culture=neutral, PublicKeyToken=6d5c3888ef60e27d' or one of its dependencies. The system cannot find the file specified.


What is confusing me is that I have everything installed. So it shouldn't give me this error.

Have you got Microsoft.Xna.Framework added to the refrences?

#22 User is offline   Prey 

  • Member
  • PipPip
  • Group: Members
  • Joined: 05-May 11
  • LocationUK

Posted 10 August 2011 - 08:26 PM

And also did you try rebuilding?

#23 User is offline   mojobojo 

  • Newbie
  • Pip
  • Group: Members
  • Joined: 31-July 11

Posted 11 August 2011 - 02:17 AM

View PostXerax, on 10 August 2011 - 03:58 PM, said:

Have you got Microsoft.Xna.Framework added to the refrences?

That was the first thing I did.

View PostPrey, on 10 August 2011 - 08:26 PM, said:

And also did you try rebuilding?

Yes, rebuild succeeds, but I still get the same error.

Edit:

Something is not right. On VS 2009 I am able to create projects with 3.1 and code in it fine. When I add the XNA 4.0 reference to the project it dose not work. But when I load it with VS 2010 the 4.0 references are not even there. But when I create a XNA 4.0 project it is fine. I think my 2 Visual Studios and 2 different XNA versions may be conflicting with each other. I have also tried copying the XNA 3.1 references to the root directory of the application. Then I get a System.BadImageFormatException.

This post has been edited by mojobojo: 11 August 2011 - 03:10 AM


#24 User is offline   Prey 

  • Member
  • PipPip
  • Group: Members
  • Joined: 05-May 11
  • LocationUK

Posted 11 August 2011 - 08:39 AM

xna 3.1 works with vs2008, xna 4 works with vs2010. That's the only order they'll work in.

Share this topic:


  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic